Block 1

Chromatic Music Production Institute Syllabus

1. Station Equipment:

>
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Computers
Interface
Power Strip
Desk

Audio Snake
Audio Converters
Monitor Hub
Speakers

Sub

Patch bay
Patch Cables
Power amps
Guitar preamps
MIDI Controller
Sound Module
Sustain Pedal
Microphones

Mic Preamp

2. PC and Mac Computer basics

>

>

>

Creating folders and sub-folders
Transferring files to student drive

Drivers, support software

>
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PRODUCTION INSTITUTE

Digital Cable basics: Firewire 400/800,
USB 2.0/3.0, MIDI

Mouse and Keyboard Functions: Right
click, Ctrl, Alt, F keys, Shift, Modifier Keys
(Alt+Tab)

Power on/off, Login,
Internet Basics: Creating Browser Tabs
File Types: .exe, .doc, etc.

Ejecting Drives and safe removal of
media

Computer Hardware: Hard drives, RAM
Memory, CPU, Video Cards, PCI/PCle
Slots, DVI/D-Sub, PS2 ports

Saving, Un-do, Re-do shortcuts

Windows 7 vs OSX ics

3. DAW Software Introduction
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The History of the DAW
Cubase

Logic

Pro Tools

Reason

4. Review Block 1

>

Quiz 1
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Block 2
5. Intro to Cubase > Grouping
> Setting up a Session » Markers
> Rulers » Folders
» Transport » Locaters
> VST Palette » Creating Project Folders
» Creating a new Project folder
» Naming a project 7. Advanced Signal Flow and Troubleshooting
> Session File, Audio folder, Misc Files > Patch Bays
» MIDI Signal Flow: Controller to Computer » Audio snakes
to DAW to Track Data
» Where to start looking
> Audio Signal Flow: Analog signal to o
Interface to Computer to DAW to Track > Go back to the beginning
Audio » Software or Hardware issues
» Device Setup and VST Audio > Keeping your cool
» VST Connections: I/O Setup > When to call support
» Production Track Types: Audio, MIDI, > When to Restart the computer
Instrument, Ruler
> Save often
» Mixing Track Types: Group, FX, Folder
» Backing up your Data
> Inspector Sections: Main, Insert, Send,
EQ, Channel, Info » Signal flow issues
> Google it and forums
6. Work Flow and Session Organization
» Key Commands and Macros 8. Review Block 2
Templates > Quiz?2

>
> Preferences
>

Coloring
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Block 3
9. Microphones and Sound Dynamics > Fix-it-in-the-Mix
» Microphone Types: Dynamic, Condenser, > Performance vs. Pitch
Ribbon

» Real instruments vs. Virtual Instruments
» Microphone Patterns: Cardioid, Omni-
directional, hyper-cardioid (Uni), figure

eight (Bi) 11. Audio Editing (Cubase)

» Phantom Power > Snapping Regions to grid

> Non-Snap Editing Regions
10. Audio Recording (Cubase) > Fades: In/Out/Crossfading
> Interface Basics: Gain, Pad, Line, Mic, DI, > Region Handles
Playback vs. Input, Output
» Cutting/Pasting
> Cable Types: Balanced XLR, %" TRS,
Unbalanced %4” TS (instrument cable) » Muting
» Channel Strip Preamp and Audio Signal » Time Compression/Expansion
Basics: Gain, EQ, Compression, Output, )
48V, -20dB Pad, Phase, Soft knee, GR/ > Tools Explained
meter, EQ/Comp, Auto, and Peak
Tuning live instruments 12. Review
Recording Latency > Quiz3

Direct recording

Gain Staging Basics

Artists Headphone Mix

Mic Level

Artist Mic placement and Pop filter
Pre-EQ

Pre-Compression
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When to multi-track vocal/instrument
parts
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13. Studio Roles:

>
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Artist

Musician
Songwriter
Producer

Arranger

Recording Engineer
Mix Engineer

Mastering Engineer

14. Working with an Artist

>
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Be prepared...

Ask lots of questions about the direction
of the song

Listen to the Demo if available

Ask if they own all the right to the track
Get a deposit up front (no exceptions)
Test your gear before the session

Create a template for the each type of
session

Make sure the Artist and musicians are
finished writing their parts before the
session starts

Make sure you know where your friends
start and your clients end

The biggest mistakes you make not
musical

>

15. The
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Who's paying for the session? You or the
client...

Desperation isn’t sexy
Charge nothing, you get nothing

Why it’s important to listen to styles you
can’t stand

Breaking Down Music Styles

mind of the listener
The Narcissist: What are you listening to?

What they expect from the picture on
the cover

Intros are dangerous
Get to the point
Beer at the opera, Wine at the beach

If you had to do it all again

16. Review

>

Quiz 4



Block 5
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17. Virtual Instruments and Plug-ins

>
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Freezing Plug-ins

Loading Plug-ins

Processing Power

Latency

Samples DFD and RAM Memory

Omnisphere, Stylus, Trilian, Addictive
Drums, Halion, Groove Agent One,

Synth Basics

Multi-timbral

Monophonic vs. Polyphonic
Arpeggiator

Transposer

18. Sequencing Basics

>

>

Setting up a Tempo BPM/Time Signature
(Click Track)

Hot Keys: Record, Play, Zero, Loop, Part
Selection, Jump to Locator, Zoom, Step
Bar, Click

Regions

Piano Roll Basics: Drawing, Coping, Dragging,
Length, Data Lanes, Snap, Grid, Tabs, Step
Input

Drum Editor Basics: Global Quantize, Lane
Quantize, Selection Tool, Drumstick Tool,
Editing Velocities

>

Score Editor

>

Multi-track vs. Merge Sequencing

19. MIDI Editing

>
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Tools: Selection, Range, Split, Glue, Erase,
Zoom, Mute, Draw, Scrub

Quantizing
Copying
Transposing
Velocity
Sustain
Modulation
Channels
Controller Data
Velocities

Note Data

20. Review

>

Quiz 5
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21. Intro to FX

>

>
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History of FX

Just because you can doesn’t mean you
need to

FX Send FX Channel Track
Setting up FX and signal routing
Inline vs. Aux Send

Send amount and Wet/Dry Amount

22. Inline Plug-ins

>

>
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Frequency Based FX
EQ and Filter
Simulator FX
Distortion

Dynamic Based FX

Compression and Limiter

23. Aux Plug-ins

>
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Modulation Based FX
Chorus

Phaser

Flanger

Ring Modulator
Time Based FX

Delay

Reverb

24. Review

>

Quiz 6
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25. Drum Sampling

>

>
>
>

Drum Tuning
Mic Placement
Gain Staging

Tracking Samples

26. Drum Sampling Editing

>

>
>
>

Editing Samples
Organizing Samples
Creating a Virtual Drum Kit

Layering samples

27. Drum Sampling Kit Creation

>

>

>

Working in Kontact
Working with Battery

Velocities

28. Review

>

Quiz 7

Block 8

29. Acoustic Guitar Sampling

>

>
>
>

Acoustic Tuning
Mic Placement
Gain Staging

Tracking Samples

30. Acoustic Guitar Sampling Editing

>

>
>
>

Editing Samples
Organizing Samples
Creating a Virtual Guitar

Layering samples

31. Acoustic Guitar Sampling Kit Creation

>

>

Working in Kontact

Velocities

32. Review

>

Quiz 8
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Block 9
33. Drum Programming 101 > Slicing Loops
» Starting with the Hi Hat » Conforming Loops to Tempo
» Define the style » Copying Loops
» Chicken or the Groove » Tempo Artifacts
> Basics 1st » REX Loops (Stylus, Reason)
» Sit back and Listen
» When cool becomes overkill 35. Creating a work library
» Just sounds like a loop > Setting up production folders
» When to pull loops from player > Setting goals
» Think like a drummer » Reusing structures and beats
» Drum fills > Integrating software into songwriting
» Regional transitions » Chicken or the Egg? Melody or the

Production

> How to make the software work for you
34. Working with Loops

» Dragging External Loops into Arrange/

Edit window
Analyzing Loop Tempo and Length 36. Review
Editing Start and End of loop > Quiz9

Combining multiple loops
Time Stretch/Compress
Creating Loops

Groove Template
Quantizing Loops

MIDI Loops
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Creating Hit points
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Block 10

37. Music Theory 101

> Music basics

> Pitch Interval Basics: Half steps, Whole

steps, Etc.

38. Chord and Scales

» Major, Minor, Diminished Chords

> The 7 Modes

» Scales Explained

39. Circle of Keys

>

Key Basics: Minor, Major, Relative, Cycle
of 5tVs/4th’s

40. Review

>

Q10

Block 11

41. Music Theory 102

>
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Piano Basics

Drum Basics

Bass Basics

Note Basics: 1/1, %, %, 1/8, 1/16, Triplets

Ear Training: Color of sound

42. How to write a POP song
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Composition and Song Structure Basics
Verse

Bridge

Chorus

Hook

Intro

Outro

Interlude

43. Chord Number and Progression Chart (1465)

» Defining the Key
» Using Numbers to write music
» Reverse engineering popular songs
» They designed it that way for a reason
» Reinventing the wheel is unnecessary
> Pop Structure vs everything else
» Fast Food
» Defining the Chord numbers
» Verse Chords
> Bridge Chords
» Chorus Chords
» Interlude Chords
44. Review
45.Q11
Block 12
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46. Bass lines 47. Playing drums
> You’'re either nodding your head, or your > Breaking down a beat
not
> The2/4
» When to use Samples
> HHvs Ride
» Recording live Bass
> Fills
> When its time to record the bass line
» Pocket
> Bass is not the easier guitar
» Groove
> Bass driven songs
» Laying back in the mix
48. Review
» Locking with the Drums
» Quiz 12
» All about the pocket

46. The Guitar as we know it

> How to get that BIG guitar sound
Solos
Tones

Re-amping the Electric Guitar
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Riffs
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Block 13

49. How to be a one man band

>

>
>
>

Creating a song in G Major
Charting the Chords
Arranging the song

Organizing the session by color (verses,
bridges, choruses, hooks, intros/outros,
interlude)

50. Tracking the instruments

>

>

Begin with the end in mind

Creating the song structure with a basic
drum beat

Recording Scratch Guitar tracks

Less is more: When to leave space for
other instruments

Redesigning the Scratch Drums
(Humanize)

Final Rhythm guitars

Recording a solid Bass line: Controlling
the listener

51. Making the 1st mix (Trial Production)

> Letting the song marinade: Time off from
listening

» Coming back to the beginning: Fresh
perspective

» Production: Filling in the black spaces

» Objective Mixing: Who's buying it

> Quick Mastering
52. Review

> Quiz 13
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Block 14
53. Automation Modes 55. Bouncing Formats
» Read » MP3
»  Write » Wave
» Latch » AIFF
> Touch > 16/24 bit
> Off » Sample Rates 44.1k and up
» Uploading and emailing tracks
54. Intro to Mixing > File Size does matter
» Quiet Monitoring
» Limiter on Master Fader 56. Review
» Mixing Drums > Quiz 14
» Bringing in the Bass
> Bringing in the Instruments
» Finding the 2D space (Panning)
» Bringing in the Vocals
» Finding the 3D Space (Time Based FX)
» Mixing with EQ
» Mixing with Compression
» Mixing with Time based FX
» Using Special FX
» Mixing with Automation
» Mixing for Multiple Formats: CD, MP3,

Movies, Commercial
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Block 15
57. Intro to Mastering
» Painting vs. Waxing
» More than one is needed

> Who should Master it

58. DAW Mastering
> Master Section
59. Standalone Mastering

> TRacks

60. Review

> Quiz 15

Block 16
61. Intro to Sound for Film

> What you’re been missing

> Jobs

62. Sound Design
» Creating sounds from scratch

> Redesigning Sounds

63. Foley

» What s Foley?

» Tracking sounds

64. Review

> Quiz 16
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Block 17

65. How to Build a custom PC

>
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Where to buy parts

Starting with the Motherboard
Compatibility issues

Minimum component requirements
Form Factors

Cases

Optical Drives

Recording PC vs Personal PC

SATA, ATA, and MOLEX connecters
RPMs

Memory Types

CPU

OEM

Putting it together

42. PC Assembly

>
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Screw Types

Motherboard and CPU assembly
Motherboard and Case assembly
Memory slots

Power supply

Installing the DVD drive
Installing the Hard Drives

Installing the Graphics Card

Connecting all the DATA and Power
Cables

67. Installing Software

>
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Boot Test

Configuring the BIOS
Installing Operating System
Updating drivers

Preparing the computer for Recording
use

Backing up essential drivers and software

68. Review

>

Quiz 17
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Block 18
69. Making Money with your Music

» Sellit vs. License it
Demo Reels last forever
Websites for promoting yourself
BMI, ASCAP

Copy writing your music
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Writing and Promoting music is a full-
time job

Y

Mixing Artists Music

» Hourly Rates vs. Flat Rates (Married to
the Project)

» Mastering Tracks

» Recycle Beats and Tracks

70. How to advertise yourself

» Creating a Resume

> Office Programs

» How to build a website
71. Design a Project Studio

» Research parts

» $3000 and $10000 Budget
» Gearslutz.com
»

Sweetwater.com

72. Review

> Quiz 18
Block 19
CMPI Certification

» Artist tracking test
Production test
Music Theory test
Mixing test
Mastering test
Trouble Shooting test

Audio Editing test
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DAW test

Graduation

> Certificate of Completion

— 4
PRODUCTION INSTITUTE

2008 Westside Lane
Woodstock, GA 30189
678-325-8696
www.chromaticmusic.com
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